App Unlock lost after installing SleepCloud

Detailed description of the problem:
The app keeps loosing the unlocked status, I have to uninstall/reinstall it every time.

Steps to reproduce:

  • Install app => Ok, unlocked
  • Install SleepCloud & restore backup
  • Re-launch app => Asks for new permissions & loose unlocked status

EDIT: Well, thought that was a good idea to add a gif showing the problem, but I guess server compression doesn’t agree

Version of Sleep as Android:
Latest beta version (20210921)
/!\ Using microG and Aurora Store (logged in with my Google account)

Hello Florian,

sorry for the issues. This is the first time I see such issue and out of top of my head I do not see how this would be related to the SleepCloud… would you please contact with more details about the purchase? Is this an in-app purchase or you have the Unlock app installed?

I’d guess this is probably linked with microG/Aurora store…
Yeah I don’t really see why this would be related to SleepCloud either, but I did try those steps few times and it really looked like it keeps the Unlocked state until I run SleepCloud (I’ve tried to not install it for a day and it stayed unlocked)…!

Hello Florian, and is it an in-app purchase or you have the Unlock app?

Thanks for the quick reply, It’s an in-app purchase !
I can email support if better suited though