App not translating data into graph

Detailed description of the problem:
I used the beta version before and everything worked as intended. I then installed the latest version available and now it reads data from my watch, but doesnt translate it into a graph and doesnt show any details ( such as sleep patterns and cycles ).
Here is a screenshot of what i mean if the other link for image is broken
Since it doesnt translate the results it wakes me up at exactly 30 minutes before my alarm.
So far since the upgrade 2 days this has happened.
The app upgrade was done by “updating” the app and not reinstalling it, to keep the data previously recorded.

Sleep as android version : 20180404
Smartphone : OnePlusOne ( 7.1.2 LineageOs rooted )
Sleep as android version on watch : 2.9
Smartwatch : Tickwatch E, running latest WearOs version

Additional info :
In “Graphs” section
“Sleep phases in list” - Check
“Hide graph peaks” - x2.5
“Sleep day cutoff” - 24:00

Edit : I was just testing some things and i went into the “test accelerometer” under “use wearables” and for some reason it seems like the app is using my phones accelerometer instead of the watches. I then unchecked it and checked back again and it looked like it was reading data from watch accelerometer. Then i restarted the app and it went back to the phones accelerometer.
Is there a way to disable phones accelerometer while the watches one is in use ?
Why doesnt it not save the setting after restarting the app even though it did in the previous version of the app.

Edit2 !!! : I Reverted back to the version 20180312BETA, the latest known working version ( using titanium backup ). Right now i tested the accelerometer recognition and its working as it should ( the accelerometer test reacts to the watch not the phone ).
The app works as intended.
I can revert back and forth between the app versions if necessary for you to come up with a fix, but i will keep this working app version for now.

Anybody gonna try to help me or not ?
I downloaded the latest release the 20180518 BETA and it still doesn’t work.
Exactly the same issue, the phone just uses its own accelerometer instead of the smartwatches.
I tried to reset the app completely ( phone and watch ), no data whatsoever, no cache, brand new installed app.
All permissions are correct and allowed both phone and smartwatch.
I tried to make the phone use sonar in hopes it would use the watches accelerometer instead but no luck.

The only working version for me is the 20180312BETA to which i will have to revert back if nothing will work on the newest versions.

Hi @jakekollins This is most probably the issue we are currently hot on with Google – they are unable to make the Google Play Services level on both the phone and the watch – but you need to have the same version of the Play Services on both devices for the communication to work.
This would explain why the revert to the old version of Sleep as Android helps - it still uses an older version of Play Services that you have on your watch.

Please update the Play Services on your watch and it should work.

Sadly that wasnt the case here. Either that or my watch simply doesnt support the latest play services update.
So i updated the play services on smartphone to the latest version available 12.6.88 ( 040300 )
Then the watch gave me problems. The version of the play services on the watch was version number 12.6.86, but the problem is the number that follows ( 050… ) when i went to download the latest play services i saw that those 3 first numbers meant to tell you the correct version to download.
Problem is the 050 doesnt exist even as previos versions in all existing in the play services APK mirror webpage.
So i then went to find which CPU architecture the tickwatch e has, and it is an ARM. The current android version on the watch is 8.0.0.
So i just downloaded this version of play services : 12.6.88 ( 090300 ) and flashed it over adb ( since there is no other way to do it ). The watch started to run a bit slow, but it did vibrate when someboy called on my phone which it never did before.
As final step i just upgraded the sleep as android app on phone to 20180518 BETA latest i could find, and slept a night to test it. ( I tested the accelerometer before that and it was using phones accelerometer even after checking and unchecking to use wearables multiple times ).
And the results are just the same as before
Either the app is not translating it correctly ( because the graph seems to be having some disturbances even though my phone is always on my table without moving the whole night ) .
Or it simply doesnt use the watches accelerometer like it should.

I dont know how else im i supposed to update the play services other then manually ( on watch ). The system update says everything is up to date, i regularly update everything within the play store.
Either i got the wrong play services, or the latest version of it is still not available for my watch.
PS for info :
The cardiogram app for example stopped doing constant monitoring with the latest system update that i did ( before this test with updating play services over here ), even though it has all the rights on phone and on watch.
050 play services ( the play services i had on my watch ) the 5 means “for mips” and the 0 means for android <5.0 All of that doesnt make sence because the watch says its android 8.0.0 and the CPU Architecture is an ARM i googled the exact CPU model. So i have no idea whats going on, the watch is not rooted or tinkered with, its completely clean and innocent.

I found out something. Apparently there is a section for Wear OS Google play services in apkmirror which takes you to the correct version of the app.
I then found out that the latest available is : Google Play services (Wear OS) 12.6.73 (050300-194189626) (028) Updated on May 10, 2018
I downloaded it and tried to install on the watch but the watch has a superior version installed ( even though its a smartphone version ) and so it doesnt let install. After some research i finally found out how to do it and now i am on that version.
The problem is that version is somehow INFERIOR to the one i had in the very beginning, which is Google Play services 12.6.85 ( 050300-197041431 ). I tried the Accelerometer with the app and of-course nothing really works.

PS : It self updated the app to 12.6.85 ( 050300-197041431 ) which is the latest version available for my watch. That version is not even in the apk mirror.
The latest for the phone is 12.6.88, but the wear os seems to be lacking behind and i cant do anything about it. So i guess i just have to revert back to the old version and use it untill they come up with an update

Thanks a lot for sharing your findings. We are actively emailing with a guy from Google about this issue and hope they’ll do something real about it…

I updated to Version 20180622 and still nothing works.
Are there any news on this thing ?
Like the only reason i bought the smartwatch is to track sleep and it doesn’t even work already for more then a month.

They finally updated play services to the latest one 12.8.74 on the watch.
So now i have the same version of play services on phone and on watch.
All other apps like wear os, mobvoi and whatnot all updated to latest version.
Sleep as android version is still 20180622

And still the accelerator on phone is being used, instead of the watch.

Problem fixed, topic can be closed.