After installing Android 10, app no longer comes to foreground when alarm goes off

Detailed description of the problem:

Several days ago I upgraded to Android 10.

Before, when an alarm went off, the phone woke from sleep; the app came to the foreground and I saw “Snooze” and “Dismiss” buttons.

Now, when an alarm goes off, the phones wakes from sleep; but the Sleep app does not come to foreground. So I have to manually open the Sleep app in order to see “Snooze” and “Dismiss” buttons.

Steps to reproduce:

Version of Sleep as Android:

I saw this with both standard and beta versions.

I figured out how to fix. Settings -> Apps -> Sleep -> In Advanced section, change “Display over other apps” to Allowed.

Hello, many thanks for feedback. Unfortunately on Android Q it is no more possible to start screens from background… we only rely on the system how it displays the alarm… in case the screen is already on when alarms starts it will just show a notiifcation… a workaround to have a full screen alarm every time is to set the permission as you did and also keep Flip to snooze enabled in Alamr settings > control… big thanks…