How to change the default alarm app for Google Assistant


#1

In an earlier Version of Android I could say:

ok, google wecke mich um 7 Uhr (german)
ok, google wake me up at 7 o’clock(english)

It started the sleep as android app and created the alarm for the next day.
But when I do it now it creates the alarm in in the stock android app (Uhr in german android).

Is there any way to change the standard alarm app or to restore the function that it does work with the assistand again ?


#2

Apparently, it does do this. I just said “OK GOOGLE, set an alarm for 5 minutes from now.”

It did not use the stock app. It did not I use Gentle Alarm.
It DID use “Sleep As Android.” I await the alarm in less than two minutes.


#3

Maybe this is just an issue of setting the default app for handling alarms on the phone?

If the default alarm handler is the stock Clock app, please go to your System settings > Apps > Clock > Open as default > Clear default settings (maybe some of those options are called a little differently but it should be there somewhere).

When you next try to set up the alarm, the system/Assistant should ask you which app would you like to use for that.


#4

It worked! It played my alarm music and everything.

Best,
Robin
@rjm_robin


#5

I can’t click anything in this menu.


#6

Any ideas @petr-urbandroid?


#7

in the sleep as android settings it looks like this:


#8

Right, I think I got it.

Tell Google Assistant to “set an alarm”, and it should respond with a dialogue:

You would have a Clock icon instead of the Sleep Android icon. Tap on that icon and you should be able to choose the app to set the alarm with. This should also set the default for the next time.


#9

That worked. Thank you very much.