Force english locale, but keep 24 hours system

From Anonymous on 2016/03/09 06:10:01 +0000

Like the title says. Currently it is possible to force the english locale text for the app which is great, but it also forces the 12 hour system with it. So just make the english locale option just change the text, not the time format.

Copied from original feature request: http://urbandroid.uservoice.com/forums/264867-sleep-as-android/suggestions/12863850-force-english-locale-but-keep-24-hours-system

From Petr Nálevka on 2018/02/19 10:07:45 +0000

Hello, please note that this is based on your system's 12/24 settings in phone settings - time and date…but we had reports that there are bugs in custom ROMs for example… anyway we simply ask the system what mode to use…no charges there and no this is the only report we have about this if this would be a non device specific issue we would be overwhelmed by emails now…

From Stefan Kirsch on 2018/02/17 17:46:26 +0000

I have the same issue with the latest version of Sleep

From Petr Nálevka on 2017/02/23 09:39:10 +0000

Hello, this is probably CM bug :frowning: hopefully gets addressed soon…

From Anonymous on 2017/02/23 09:02:57 +0000

I have the same problem with my Nexus 5 and Cyanogenmod.
24h format is enabled in system settings.

This request still a thing. The current state is super annoying if you live in a country which doesn’t use the AM/PM system … I always accidentally set the alarm to midnight instead of noon when giving me an extra hour of sleep (usually my alarm is set to 11:00 am), because 11:00 AM is 11:00 but 12:00 AM is 00:00 …

I just overslept because of the exact problem you described. Once I turned “force English” off again the system settings weren’t overwritten any more and everything worked as expected.

I use a Huawei P30 Pro with the newest official version, so this problem isn’t just exclusive to custom ROMs.

Hello guys, I cannot reproduce the issue. Even when I set the app to force English which will set 12-hour format for the app… if I than set Phone settings - System - Date & Time - 24-hour format CHECKED… all my times in Sleep as Android are 24-hour formatted…

Is there some way that I can help you pin this down? Or is it easier to just add a selection for 12h/24h/system-default in the settings?

I also have the Huawei P30 Pro and had the same problems; force English -> 12-hour clock -> Overslept due to PM/AM…

My system was already set to 24-hour clock but I still had the 12-hour problem. However, I tried to set my system to 12-hour and then back to 24-hour which seemed to solve the problem.

A permanent solution would perhaps be for the app to check the system settings direcly when forcing another language?