Fitbit Ionic/Versa beta integration

Perfect! Thank you so much!

How come other apps are able to track from my Inspire HR just by logging into my fitbit account? I only ask because I’ve tried another app and the sleep recordings were terrible compared to yours.

That’s because they don’t use the raw sensor data but the data that have been recorded and aggregated (meaning - sleep phases computed) by Fitbit already. So all they do is just display the results. That’s why we cannot do it the same way. The strength of Sleep as Android is in the state of the art sleep phase detection algorithms from raw sensor data.

2 Likes

I cant seem to find the App on the store has it been hidden?

Hi, I tried it several times to be sure, but I have to say nothing has been changed with my Versa lite.

I also have the following minor issues:

  • The sensor test does not work because the helper module is not started
  • If I able to start the helper module somehow (see next point) the sensor test still doesn’t show anything but a circulating line.
  • After reboot the helper module starts automatically after a while.
  • Sometimes the watch does not recognize the connection with the phone, so although the phone thinks it’s connected to the watch, the watch still waits for the connection.

Oh, and I’m still more than happy to help. I have some generic coding experience and I’m not afraid getting my hand dirty with some debugging or installing an experimental version, which for example print out information beside sending it to the phone or do some other tricks to get some debug info.

1 Like

You can’t as it is not public yet. You have to use the direct link in this thread on the phone to open the app store.

Besides occasional problems connecting the phone to the app (usually requiring some kind of restart of either Bluetooth,the phone or the watch) I can report that with the original versa it is is already working decently.

1 Like

A post was split to a new topic: Fitbit Versa question

I couldn’t wait more, so I registered to Fitbit as a developer and created my first app, which collects and show all sensors data. (I just compiled and published the template.) And now I can see the problem. In my Versa lite, the accelerometer doesn’t show anything. It exists, but have no values. Tomorrow I will do some more research.

So, I played with my watch a bit. And unfortunately I found no solution or any kind of evidence of it’s working by any means. The HR sensor is working fine, but we already knew this. I tried the official way to read the values and later I created a time-based callback but was not able to read any values. Even the activated class member was false (or none). I’m not too happy now.

Here it is the answer to my question in the FitBit forum: https://community.fitbit.com/t5/SDK-Development/No-acceleration-data-in-Versa-Lite/m-p/3660794#M9478

Good God, I should’ve suspected that. Thanks a lot for trying it and checking on the Fitbit forums. So this seems like a temporary issue hopefully so we can go ahead and publish the app for the Ionic and big Versa.

I use a mi-band for tracking but i realy want my versa to be my sleeptracker.
I have the latest beta of sleep as android and the latest versa app (1.5)
In SaA i selected the fitbit als my device. (no notification showed up about fitbit server)

The devices aren’t connecting.
When i start my sensor test in SaA and then open the app on my versa, it stays on “connecting…” state forever. Rebooting both devices did not do the trick.

I am using a moto g5s plus with all latest updates installed

Any advice for getting this to work?

2 Likes

With my Ionic the last night the same problem. Before it was working, I’m not sure, what was problem last night.
I will check again and repost.

As replay for both @Doray and @Martin_Strell

if shutdown/start Ionic/Versa and restart cell phone does not work, try reinstall the watch companion app.
also check the watch and the Fitbit app are communicating fine, if the Fitbit app does not see the watch, SaA will not be able to see it.
Some times it takes me to force close SaA and Fitbit app for the watch to connect to SaA.

Hope it helps.

This night was working again very well.
I don’t know what was wrong.
You’re right. Sometimes I try and when it not works I close both apps and normally when I retry it works fine.
But the night before I tried a few times.
So was strange but I don’t mind.

Fitbit Ionic user here. Recently downloaded the app. I have been unable to get the app to connect with my fitbit. I have tried various things
3 different android devices
reset the watch
“Classic” bluetooth setting connection from watch
Watch shows “Connecting…” and when the app gets to the end of the 2 minutes it starts tracking without the watch.
Normal fitbit app sync seems to be working fine. All day sync and always connected are on.
Any other thoughts to try are appreciated.

My Pixel 3 XL updated to 10!
Now every night I need to restart the phone to be able to start the sleep tracking.
When I start the tracking it will not connect even if I restart the Ionic, the only way is restarting the cell.

Note: we have not have an update in a month. There are any new news?

@devonalysha did you try to restart both the watch and the cell? did you uninstall the companion app on the Fitbit and reinstalled it again?

@ludohavil, restarted and both watch as well as one of the 3 android devices have had a factory reset this week.

I’ve been using the integration with my Versa for about two months now and it worked good, only problem was connecting sometimes, but that was often fixed by syncing the Versa with the fitbit app.

I’ve now upgraded to a Versa 2, the app cannot be installed at the moment. Is there an eta when it will be available for the new Watch?

Thanks for the awesome work