START sleep tracking with AUTOMATE APP PLEASE HELP


#1

Hi,

I have sleep android on phone.

I have automated app on phone.

I downloaded the FLOW file and imported it on automated APP.

What part I need to edit so it can automatically start sleep tracking at whatever time I choose it to start… for example 7:00 AM?

Thanks in advance!

PS: I have read the instructions, don’t understand a thing of it.


#2

I changed the timing on the blocks where I can insert a time… but all I get when the TIME comes is a window with a couple of options to choose from… this does not start SLEEP TRACKING for me…

PLS help


#3

Which “automated app” do you use, i.e. name and preferably Google Play URL?

And which flow do you use?

There are several apps for automation and I don’t think their programming ‘language’ is the same.
I used the ‘Automate’ app:
https://play.google.com/store/apps/details?id=com.llamalab.automate

I wrote a simple flow to wait till a specific - fixed - time of day and then send a ‘Start sleep tracking’ Action to Sleep as Android’s Tasker plugin.

For some reason, I could not save the flow to a (.flo) file and copy it, so here are the instructions which make up the flow:

  • ‘Flow beginning’ block:
    TITLE
    Start SaA at
    Tap ‘Install homescreen shortcut’

  • ‘Await time’ block:
    OPTIONS
    PROCEED
    [Inexact]
    TIME OF DAY
    17:17 -> 02:00

    TIME ZONE
    Europe/Amsterdam
    WAKE UP
    untick ‘Awake device’

  • ‘App start’ block:
    PACKAGE
    com.urbandroid.sleep (picked from list)

  • ‘Plug-in action’ block:
    OPTIONS
    PLUG-IN
    Sleep (picked from list)
    Configure… -> Start sleep tracking ->
    DESCRIPTION
    Start sleep tracking

I hope this helps. Good luck.


#5

Hi, thanks a lot!! I did what you said . However it indeed does start sleep as Android but only the interface not the actual tracking


#6

Then something must be wrong in the ‘Plug-in action’ block.

You can also try to swap the ‘Await time’ block and the ‘App start’ block. That allows the app more time to start up, before it gets the ‘Start sleep tracking’ action in the ‘Plug-in action’ block.


#7

Tried the switching didn’t work.

Perhaps the app is the problem


#8

Hi, please make sure that Settings > Services > Tasker is enabled in Sleep as Android.


#9

You seem to use a different app than the ‘Automate’ app I mentioned before, because the app’s icon, etc. are different. So probably my instructions do not translate one-to-one to your app.

BUT, as far as I can tell, you have not set an ACTION in the ‘Plug-in action’ block. You have given the DESCRIPTION ‘Start sleep tracking’, but that is just text and could be anything. But in the ‘ACTION’ field of your last screenshot, you do not seem to have set the ACTION ‘Start sleep tracking’. This ACTION is the part which starts the actual sleep tracking, so without it, nothing happens, which is exactly what you have found.

Hope this helps.


#10

Indeed I had to enable tasker in sleep as android app!

Thanks a lot you guys! really appreciate it! :slight_smile: