How to let Lucid dreaming cue vibrate the Mi Band 2, NOT the phone?


#1

In order to trigger/wake me, but not disturb my wife, I would like the Lucid dreaming cue vibrate the Mi Band 2 instead of the phone.

But I can not get that to work.

For normal (smart) alarms, one can do this by setting ‘Vibrate’ to ‘Disabled’ and ‘Vibrate (Wearables)’ to ‘From start’ or ‘After … minutes’.

But for the Lucid dreaming cue, I do not see such settings, only ‘Vibrate’ on or off (on the Settings -> Lucid dreaming page).

When setting ‘Vibrate’ to on (ticked) and then tapping ‘Preview’, both the Mi Band 2 and the phone vibrate (first the Mi Band 2, then the phone).

When setting ‘Vibrate’ to off (unticked) and then tapping ‘Preview’, only the Mi Band 2 vibrates, so this seems the setting I’m looking for.

But, when the actual Lucid Cue triggers, the Mi Band 2 does not vibrate, i.e. nothing happens.

Of course I cannot be a 100% sure that nothing happens, because I’m asleep, but even with ‘Loop audio 10x’, i.e. 10 vibrations, I do not notice anything, while such vibrations (as an alarm) do wake me up.

I even tried with ‘Vibrate’ set to on (ticked), but then only the phone vibrates, not the Mi Band 2.

So can this (let Lucid dreaming cue vibrate Mi Band 2, NOT the phone) be done?

If so, how?

If not, is this a bug, a design limitation, other?

Thanks in advance for any and all responses.

N.B.:

The Lucid dreaming cues DO occur, i.e. there are markers in the sleep-graphs, both in the app and in SleepCloud.

The Lucid dreaming ‘Ringtone’ is ofcourse set to ‘Silent’, because I do not want a sound to disturb my wife.


#2

This posting is to report that I have found a combination of settings which gives the desired Lucid dreaming cues:

  • NO sound.
  • Vibration on Mi Band 2.
  • NO vibration on phone.

The settings are:

[Menu -> Settings -> Sleep -> Lucid dreaming ->]

  • Enabled [V]
  • Ringtone set to ‘Silent’.
  • Volume set to 1% (just to be safe).
  • Vibrate [V]
  • Loop audio set to the desired number of vibrates.

With these settings, the Preview is still wrong, because the Preview will vibrate the Mi Band 2 and the phone, but the actual Lucid dreamingcues are correct.

So this issue is:

  • A documentation problem, because it’s not evident that ‘Vibrate [V]’ will vibrate the Mi Band 2, but not the phone.

  • A bug in the Preview part.

I hope these issue will be fixed and that this posting is useful for others as a workaround.


Improve Lucid Dreaming with wearables
Anti snoring on MiBand 2
#3

i have (had?) the same problem as you in your start posting and will try this options. i thought that vibrate means that my phone will vibrate, not that the mi band 2 will vibrate. if your bugfix / help will work, i really really say thank you :slight_smile: i will try it this night & hoping for the best. thanks in advance for your tip.


#4

Hi KnightMajor,

I tried your recommended settings, but i am not sure, if the Alarm on my mi band really occured or when it occured.
You said: “The Lucid dreaming cues DO occur, i.e. there are markers in the sleep-graphs, both in the app and in SleepCloud.”
I can’t find any markers, neither in the Sleep as Android nor in “Notify and Fitnes”-App (I use this one instead of “Tools & Mi Band”). I also checked the sleep-yxport.backup.csv and prefs.xml and didnt find anything.
Can you tell me, where I have to look?

By the way: great work you are doing here! … did you have any lucid dreams already?


#5

Hi kusuri!

Wie läuft es bei dir? How is it going for you? Did you manage to have any lucid dreams already?


#6

Hi Hektor,

Look in the sleep graphs in the Sleep as Android app, i.e. on the main screen tap the three vertical bars (long-short-long) icon. This will list your sleep graphs. Tap on a sleep graph which should have Lucid dreaming cues. The app will now show the detailed sleep graph (with Deep sleep percentage, Duration, etc.). In the top graph you should see the Lucid dreaming cues as a sort of a slanted black exclamation mark (’!’) in a white circle.

I cannot post a screen shot as I am on holiday/vacation and have only very unreliable Intenet access.

If you can not find what I’m talking about, then let me know and I will try to post a screen shot after my holiday/vacation.


#7

Hi KnightMayor

thank you for your quick response! Was very helpful.
As it seams the app is sending out quite a lot of cues over one night. 9 of them are being displayed at least.
What seems to me as a little strange is, that these cues are being sent even in Not-REM-Phases. Early at night only now and then, at the end of the night in a very close pattern. Do you have an idea, what Triggers these cues if not the REM-phases?

By the way … did you get lucid with the help of this app and your wearable already? … would love to hear a “yes” :wink:


#8

Hi Hektor,

Glad to hear you found the Lucid dreaming cues.

Yes, there indeed seem to be way too many LD cues, also in non-REM phases. Hopefully the developer(s) will see this post/thread and explain how the SaA app decides to give a LD cue.

For me, both LD cues and REM phase detection seems to not match the real REM phases. I also have a Fitbit Alta HR tracker (can not be integrated with the SaA app) and the REM phases show by that device much more closely match the real REM phases which I noted down.

I have only had a few Lucid dreams, but LD is not my main goal. My main goal is for the LD cues or/and the ~REM events to wake me up from my nightmares. Hence my nickname/nym, KnightMayor -> nightmare.